메인 컨텐츠로 가기

Excel에서 IP 주소를 낮은 것에서 높은 것으로 빠르게 정렬하는 방법은 무엇입니까?

일반적으로 정렬 기능을 사용하여 Excel에서 문자열을 정렬합니다. 그러나 정렬에 필요한 IP 주소가있는 경우 아래 스크린 샷과 같이 정렬 기능을 직접 사용하면 정렬 순서가 잘못 될 수 있습니다. 이제 Excel에서 IP 주소를 빠르고 정확하게 정렬하는 몇 가지 방법이 있습니다.

정렬 기능에 의한 잘못된 정렬 올바른 정렬
문서 정렬 IP 1 문서 정렬 IP 2

수식으로 IP 주소 정렬

VBA로 IP 주소 정렬

텍스트를 기준으로 IP 주소를 열로 정렬


수식으로 IP 주소 정렬

수식을 사용하여 IP 주소를 입력 한 다음 정렬합니다.

1. IP 주소 옆에있는 셀을 선택하고 다음 수식을 입력합니다.

=TEXT(LEFT(A1,FIND(".",A1,1)-1),"000") & "." & TEXT(MID(A1,FIND( ".",A1,1)+1,FIND(".",A1,FIND(".",A1,1)+1)-FIND(".",A1,1)-1),"000") & "." & TEXT(MID(A1,FIND(".",A1,FIND(".",A1,1)+1)+1,FIND(".",A1, FIND(".",A1,FIND(".",A1,1)+1)+1)-FIND(".",A1,FIND(".",A1,1)+1)-1), "000") & "." & TEXT(RIGHT(A1,LEN(A1)-FIND(".",A1,FIND(".",A1,FIND( ".",A1,1)+1)+1)),"000")

키를 눌러 엔터 버튼 키를 누르고 채우기 핸들을 셀 위로 끌어이 수식을 적용합니다.
문서 정렬 IP 3

2. 수식 결과를 복사하고 다음 열에 값으로 붙여 넣습니다. 스크린 샷보기 :

문서 정렬 IP 4
문서 정렬 IP 5

3. 붙여 넣은 값을 선택한 상태로 유지하고 Data > A부터 Z까지 정렬.
문서 정렬 IP 6

4. 에서 Waring 정렬 대화, 유지 선택 확장 확인.
문서 정렬 IP 7

5. 클릭 종류. 이제 IP 주소가 낮은 것에서 높은 것으로 정렬되었습니다.
문서 정렬 IP 2

도우미 열을 제거 할 수 있습니다.


VBA로 IP 주소 정렬

다음은 도움이 될 수있는 VBA 코드입니다.

1. 프레스 Alt + F11 활성화하는 키 응용 프로그램 용 Microsoft Visual Basic 창.

2. 클릭 끼워 넣다 > 모듈, 코드를 복사하여 빈 스크립트에 붙여 넣습니다.

VBA : IP 주소 채우기

Sub FormatIP()
'UpdatbyExtendoffice20171215
    Dim xReg As New RegExp
    Dim xMatches As MatchCollection
    Dim xMatch As Match
    Dim xRg As Range
    Dim xCell As Range
    Dim I As Long
    Dim xArr() As String
    On Error Resume Next
    Set xRg = Application.InputBox("Select cells:", "KuTools For Excel", Selection.Address, , , , , 8)
    If xRg Is Nothing Then Exit Sub
    With xReg
        .Global = True
        .Pattern = "\d{1,3}\.+\d{1,3}\.+\d{1,3}\.+\d{1,3}"
        For Each xCell In xRg
            Set xMatches = .Execute(xCell.Value)
            If xMatches.Count = 0 Then GoTo xBreak
            For Each xMatch In xMatches
                xArr = Split(xMatch, ".")
                For I = 0 To UBound(xArr)
                    xArr(I) = Right("000" & xArr(I), 3)
                    If I <> UBound(xArr) Then
                        xArr(I) = xArr(I) & "."
                    End If
                Next
            Next
            xCell.Value = Join(xArr, "")
xBreak:
        Next
    End With
End Sub

문서 정렬 IP 8

3. 그런 다음 도구 > 참고, 확인 Microsoft VBScript 정규식 5.5 터지는 대화 상자에서.

문서 정렬 IP 9
문서 정렬 IP 10

4. 클릭 OK 키를 누릅니다 F5 키를 누르면 작업할 범위를 선택하라는 대화 상자가 나타납니다.
문서 정렬 IP 11

5. 클릭 OK. 그러면 IP 주소가 XNUMX으로 채워집니다.

6. IP 주소를 선택하고 Data > A부터 Z까지 정렬 정렬합니다.


텍스트를 기준으로 IP 주소를 열로 정렬

실제로 텍스트를 열로 변환 기능은 Excel에서도 도움이 될 수 있습니다.

1. 사용하는 셀을 선택하고 Data > 텍스트를 열로. 스크린 샷보기 :
문서 정렬 IP 12

2. 에서 텍스트를 열 마법사로 변환 대화 상자에서 다음과 같이하십시오.

체크 구분 된그리고 클릭 다음 보기;

체크 기타 및 유형 . 텍스트 상자에 넣고 클릭하세요. 다음 보기;

결과를 저장하려면 IP 주소 옆에 있는 셀을 선택하세요. 딸깍 하는 소리 마감재 .

문서 정렬 IP 13
문서 정렬 IP 14
문서 정렬 IP 15

3. IP 주소와 분할 셀이 포함된 모든 셀을 선택하고 클릭합니다. Data > 종류.
문서 정렬 IP 16

4. 에서 종류 대화상자, 클릭 레벨 추가 B 열에서 E 열(분할 셀)로 데이터를 정렬합니다. 스크린샷 보기:
문서 정렬 IP 17

5. 클릭 OK. 이제 열이 정렬되었습니다.
문서 정렬 IP 18


최고의 사무 생산성 도구

인기 기능: 중복 항목 찾기, 강조 표시 또는 식별   |  빈 행 삭제   |  데이터 손실 없이 열이나 셀 결합   |   수식없이 반올림 ...
슈퍼 조회: 다중 기준 VLookup    다중 값 VLookup  |   여러 시트에 걸친 VLookup   |   퍼지 조회 ....
고급 드롭다운 목록: 드롭다운 목록을 빠르게 생성   |  종속 드롭다운 목록   |  다중 선택 드롭 다운 목록 ....
열 관리자: 특정 개수의 열 추가  |  열 이동  |  Toggle 숨겨진 열의 가시성 상태  |  범위 및 열 비교 ...
특색 지어진 특징: 그리드 포커스   |  디자인보기   |   큰 수식 바    통합 문서 및 시트 관리자   |  리소스 라이브러리 (자동 텍스트)   |  날짜 선택기   |  워크 시트 결합   |  셀 암호화/해독    목록으로 이메일 보내기   |  슈퍼 필터   |   특수 필터 (굵게/기울임꼴/취소선 필터링...) ...
상위 15개 도구 세트12 본문 도구 (텍스트 추가, 문자 제거,...)   |   50+ 거래차트 유형 (Gantt 차트,...)   |   40+ 실용 방식 (생일을 기준으로 나이 계산,...)   |   19 삽입 도구 (QR 코드 삽입, 경로에서 그림 삽입,...)   |   12 매출 상승 도구 (숫자를 단어로, 환율,...)   |   7 병합 및 분할 도구 (고급 결합 행, 셀 분할,...)   |   ... 그리고 더

Excel용 Kutools로 Excel 기술을 강화하고 이전과는 전혀 다른 효율성을 경험해 보세요. Excel용 Kutools는 생산성을 높이고 시간을 절약하기 위해 300개 이상의 고급 기능을 제공합니다.  가장 필요한 기능을 얻으려면 여기를 클릭하십시오...

kte 탭 201905


Office Tab은 Office에 탭 인터페이스를 제공하여 작업을 훨씬 쉽게 만듭니다.

  • Word, Excel, PowerPoint에서 탭 편집 및 읽기 사용, Publisher, Access, Visio 및 Project.
  • 새 창이 아닌 동일한 창의 새 탭에서 여러 문서를 열고 만듭니다.
  • 생산성을 50% 높이고 매일 수백 번의 마우스 클릭을 줄입니다!
Comments (8)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
Traducido al español:
=TEXTO(IZQUIERDA(A1,ENCONTRAR(".",A1,1)-1),"000") & "." & TEXTO(EXTRAE(A1,ENCONTRAR( ".",A1,1)+1,ENCONTRAR(".",A1,ENCONTRAR(".",A1,1)+1)-ENCONTRAR(".",A1,1)-1),"000") & "." & TEXTO(EXTRAE(A1,ENCONTRAR(".",A1,ENCONTRAR(".",A1,1)+1)+1,ENCONTRAR(".",A1, ENCONTRAR(".",A1,ENCONTRAR(".",A1,1)+1)+1)-ENCONTRAR(".",A1,ENCONTRAR(".",A1,1)+1)-1), "000") & "." & TEXTO(DERECHA(A1,LARGO(A1)-ENCONTRAR(".",A1,ENCONTRAR(".",A1,ENCONTRAR( ".",A1,1)+1)+1)),"000")
This comment was minimized by the moderator on the site
Thanks for your help on translating the formula.
This comment was minimized by the moderator on the site
This is great! Very much appreciated. It would be nice to add to the VB code to reverse (put back) the IP's in the original format (without the extra leading 0's) after having sorted them. :) I would be very interested in that where you can run this script, sort results, then revert back to original format.
This comment was minimized by the moderator on the site
thank you, very useful !
This comment was minimized by the moderator on the site
la formule traduite en Francais :
=TEXTE(GAUCHE(I6;TROUVE(".";I6;1)-1);"000") & "." & TEXTE(STXT(I6;TROUVE( ".";I6;1)+1;TROUVE(".";I6;TROUVE(".";I6;1)+1)-TROUVE(".";I6;1)-1);"000") & "." & TEXTE(STXT(I6;TROUVE(".";I6;TROUVE(".";I6;1)+1)+1;TROUVE(".";I6; TROUVE(".";I6;TROUVE(".";I6;1)+1)+1)-TROUVE(".";I6;TROUVE(".";I6;1)+1)-1); "000") & "." & TEXTE(DROITE(I6;NBCAR(I6)-TROUVE(".";I6;TROUVE(".";I6;TROUVE( ".";I6;1)+1)+1));"000")
This comment was minimized by the moderator on the site
Merci pour la traduction !
This comment was minimized by the moderator on the site
Why does the formula not work for the last octet? It adds zeros to the 3rd octet but not the last? So frustrating.
This comment was minimized by the moderator on the site
I have tested the formula before I post it, it can work for the last octer. Have you checked the formula you pasted is correct?
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations