메인 컨텐츠로 가기

Excel에서 대각 행렬을 추출하는 방법은 무엇입니까?

워크 시트에 다음 데이터가 있고 이제 표시된 스크린 샷과 같이 데이터 범위에서 대각 행렬 값을 추출해야한다고 가정합니다. Excel의 행렬에서 대각선으로 값을 추출하려고 시도한 적이 있습니까?

doc-추출-대각선-1

수식을 사용하여 Excel에서 대각 행렬 추출


화살표 블루 오른쪽 거품 수식을 사용하여 Excel에서 대각 행렬 추출

다음은 행렬 범위에서 대각선으로 값을 얻는 데 도움이되는 간단한 공식입니다. 다음과 같이하십시오.

1. 데이터 옆의 빈 셀에 다음 수식을 입력하십시오. = INDEX (A1 : E1,, ROWS ($ 1 : 1)), 스크린 샷 참조 :

doc-추출-대각선-1

2. 그런 다음 오류 값이 표시 될 때까지 채우기 핸들을 범위로 끕니다. 그리고 대각 행렬 값은 다음과 같이 왼쪽 위에서 오른쪽 아래로 추출되었습니다.

doc-추출-대각선-1

3. 마침내 필요에 따라 오류 값을 삭제할 수 있습니다.

배송 시 요청 사항:

1. 주장 A1 : E1 대각선 셀 값을 추출하려는 첫 번째 행 범위이며 필요에 따라 변경할 수 있습니다.

2.이 수식은 5 열과 5 행과 같이 동일한 열 번호와 행 번호를 가진 범위 셀에만 적용 할 수 있습니다.


관련 기사 :

Excel에서 범위의 대각선을 합산하는 방법은 무엇입니까?

최고의 사무 생산성 도구

인기 기능: 중복 항목 찾기, 강조 표시 또는 식별   |  빈 행 삭제   |  데이터 손실 없이 열이나 셀 결합   |   수식없이 반올림 ...
슈퍼 조회: 다중 기준 VLookup    다중 값 VLookup  |   여러 시트에 걸친 VLookup   |   퍼지 조회 ....
고급 드롭다운 목록: 드롭다운 목록을 빠르게 생성   |  종속 드롭다운 목록   |  다중 선택 드롭 다운 목록 ....
열 관리자: 특정 개수의 열 추가  |  열 이동  |  Toggle 숨겨진 열의 가시성 상태  |  범위 및 열 비교 ...
특색 지어진 특징: 그리드 포커스   |  디자인보기   |   큰 수식 바    통합 문서 및 시트 관리자   |  리소스 라이브러리 (자동 텍스트)   |  날짜 선택기   |  워크 시트 결합   |  셀 암호화/해독    목록으로 이메일 보내기   |  슈퍼 필터   |   특수 필터 (굵게/기울임꼴/취소선 필터링...) ...
상위 15개 도구 세트12 본문 도구 (텍스트 추가, 문자 제거,...)   |   50+ 거래차트 유형 (Gantt 차트,...)   |   40+ 실용 방식 (생일을 기준으로 나이 계산,...)   |   19 삽입 도구 (QR 코드 삽입, 경로에서 그림 삽입,...)   |   12 매출 상승 도구 (숫자를 단어로, 환율,...)   |   7 병합 및 분할 도구 (고급 결합 행, 셀 분할,...)   |   ... 그리고 더

Excel용 Kutools로 Excel 기술을 강화하고 이전과는 전혀 다른 효율성을 경험해 보세요. Excel용 Kutools는 생산성을 높이고 시간을 절약하기 위해 300개 이상의 고급 기능을 제공합니다.  가장 필요한 기능을 얻으려면 여기를 클릭하십시오...

kte 탭 201905


Office Tab은 Office에 탭 인터페이스를 제공하여 작업을 훨씬 쉽게 만듭니다.

  • Word, Excel, PowerPoint에서 탭 편집 및 읽기 사용, Publisher, Access, Visio 및 Project.
  • 새 창이 아닌 동일한 창의 새 탭에서 여러 문서를 열고 만듭니다.
  • 생산성을 50% 높이고 매일 수백 번의 마우스 클릭을 줄입니다!
Comments (3)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
buongiorno, purtroppo sto cercando di usare la formula di somma in diagonale da basso a sinistra ad alto a destra

=SOMMA($D$12:F14*((RIGHE($D$12:F14)+1-RIF.RIGA($D$12:F14))=RIF.COLONNA($D$12:F14)))

in un excel in italiano... la formula però mi restituisce 0 ... è come se non verificasse mai la condizione (RIGHE($D$12:F14)+1-RIF.RIGA($D$12:F14))=RIF.COLONNA($D$12:F14) come positiva
This comment was minimized by the moderator on the site
Hi.please teach us how to do the process inverse.
This comment was minimized by the moderator on the site
Thanks it help! i like it
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations